我喜欢用wordpress 做网站,最近这几年一直在用,这个问题还是第一次遇到,因为在淘宝上买了一个便宜的香港空间主机,迁数着用的那种,一般的服务器技术人员配置的不存在这种问题的,

安装网站完成后,不般是访问网站首页还是后台wp-admin/index.php 会显示“您的PHP似乎没有安装运行WordPress所必需的MySQL扩展”,出现原因是网站程序匹配的主机服务器版本不一样,要么高了,要么低啦。所以这个时候我们有两种解决方案,

第一个方法是重装一下程序,最新版本或者比较新的版本,覆盖老的版本即可。这个没什么说的, 比如我喜欢wprdpress3.6版本,那么这个时候重新下载最新的网站程序,比如4.8版本的程序或之上版本,重新上传覆盖即可,然后再访问网站首页还是后台wp-admin/index.php就不会有这个提示了。

第二个方法是降低我们网站PHP程序版本号,达到程序和网站服务器主机配置相匹配。比如我开始传的是wprdpress3.6版本。那么较匹配的PHP版本号是5.2或者5.4。如果你的PHP程序版本号是5.6,甚至是7.0、7.2之类的。那就尽量的就要降低版本。这个是比较快的解决方法。重新下载最新的网站程序,重新安装上传覆盖,是比较费时间的。

找到你购买的空间主机服务商,登陆进去,进入到管理主机的界面,有一个“更改PHP程序版本号”功能,执行操作即可。如果人家没有开放这个功能,那你只能采用第一个解决方案了。

您的PHP似乎没有安装运行WordPress所必需的MySQL扩展就是这样解决的,遇到问题不要慌,找到原因,对症下药,也能药到病解,